Информатика на пять О нас
 Добавить в избранное
5byte.ru
 Теория
 8 класс
 9 класс
 10 класс
 11 класс
Задания
 8 класс
 9 класс
 10 класс
 11 класс
Книги
Тесты
ЕГЭ
Turbo Pascal 7
 Описание
 Задачи
HTML
Рефераты

Основные типы и форматы данных

В работе с электронными таблицами можно выделить три основных типа данных: числа, текст и формулы.

Числа. Для представления чисел могут использоваться несколько различных форматов (числовой, экспоненциальный, дробный и процентный). Существуют специальные форматы для хранения дат (например, 25.09.2003) и времени (например, 13:30:55), а также финансовый и денежный форматы (например, 1500,00р.), которые используются при проведении бухгалтерских расчетов.

По умолчанию для представления чисел электронные таблицы используют числовой формат, который отображает два десятичных знака числа после запятой (например, 195,20).

Экспоненциальный формат применяется, если число, содержащее большое количество разрядов, не умещается в ячейке. В этом случае разряды числа представляются с помощью положительных или отрицательных степеней числа 10. Например, числа 2000000 и 0,000002, представленные в экспоненциальном формате как 2 × 106 и 2 × 10-6, будут записаны в ячейке электронных таблиц в виде 2,00Е+06 и 2,00Е-06.

По умолчанию числа выравниваются в ячейке по правому краю. Это объясняется тем, что при размещении чисел друг под другом (в столбце таблицы) удобно иметь выравнивание по разрядам (единицы под единицами, десятки под десятками и т. д.).

Текст. Текстом в электронных таблицах является последовательность символов, состоящая из букв, цифр и пробелов. Например, последовательность цифр "2004" - это текст. По умолчанию текст выравнивается в ячейке по левому краю. Это объясняется традиционным способом письма (слева направо).

Формулы. Формула должна начинаться со знака равенства и может включать в себя числа, имена ячеек, функции и знаки математических операций. Однако в формулу не может входить текст.

Например, формула =А1+В1 обеспечивает сложение чисел, хранящихся в ячейках А1 и В1, а формула =А1*5 - умножение числа, хранящегося в ячейке А1, на 5. При изменении исходных значений, входящих в формулу, результат пересчитывается немедленно.

В процессе ввода формулы она отображается как в самой ячейке, так и в строке формул (рис. 1.1). После окончания ввода, которое обеспечивается нажатием клавиши {Enter}, в ячейке отображается не сама формула, а результат вычислений по этой формуле.

Рис. 1.1. Ввод формул

Для просмотра формулы необходимо выделить ячейку с формулой, в строке формул появится введенная ранее формула. Для редактирования формулы необходимо щелкнуть по ячейке или строке формул и провести редактирование. Для одновременного просмотра всех введенных формул можно задать специальный режим отображения формул, при котором в ячейках отображаются не результаты вычислений, а сами формулы.

Ввод и копирование данных. Ввод в ячейки чисел, текстов и формул производится с помощью клавиатуры.

Ввод в формулы имен ячеек можно осуществлять выделением нужной ячейки с помощью мыши.

Данные можно копировать или перемещать из одних ячеек или диапазонов ячеек в другие ячейки или диапазоны ячеек. В процессе копирования можно вставлять в ячейки не только сами данные, но и формат данных и параметры оформления ячеек (тип границы и цвет заливки).

Для быстрого копирования данных из одной ячейки сразу во все ячейки определенного диапазона используется специальный метод: сначала выделяется ячейка и требуемый диапазон, а затем вводится команда [Заполнитъ-вниз] (вправо, вверх, влево).

Контрольные вопросы

1. Какие типы данных могут обрабатываться в электронных таблицах?

2. В каких форматах данные могут быть представлены в электронных таблицах?

Задания для самостоятельного выполнения

1. Задание с кратким ответом. Запишите формулы:

    - сложения чисел, хранящихся в ячейках А1 и В1;
    - вычитания чисел, хранящихся в ячейках A3 и В5;
    - умножения чисел, хранящихся в ячейках С1 и С2;
    - деления чисел, хранящихся в ячейках А10 и В10.

Относительные, абсолютные и смешанные ссылки

В формулах могут использоваться ссылки на адреса ячеек. Существуют два основных типа ссылок: относительные и абсолютные. Различия между относительными и абсолютными ссылками проявляются при копировании формулы из активной ячейки в другие ячейки.

Относительные ссылки. При перемещении или копировании формулы из активной ячейки относительные ссылки автоматически изменяются в зависимости от положения ячейки, в которую скопирована формула. При смещении положения ячейки на одну строку в формуле изменяются на единицу номера строк, а при перемещении на один столбец на одну букву смещаются имена столбцов.

Так, при копировании формулы из активной ячейки С1, содержащей относительные ссылки на ячейки А1 и В1, в ячейку D2 имена столбцов и номера строк в формуле изменятся на один шаг соответственно вправо и вниз. При копировании формулы в ячейку ЕЗ имена столбцов и номера строк в формуле изменятся на два шага соответственно вправо и вниз и т. д. (табл. 1.3).

Таблица 1.3. Относительные ссылки
  А В С D Е
1     =A1*B1    
2       =B2*C2  
3         =C3*D3

Создадим в электронных таблицах фрагмент таблицы умножения. В столбцах А и В разместим числа от 1 до 9, а в столбце С - их произведения.

Для этого введем в ячейки А1 и В1 число 1, в ячейку С1 - формулу =А1*В1, а в ячейки А2 и В2 - формулы =А1+1 и =В1+1 с относительными ссылками. Тогда для заполнения таблицы достаточно будет просто скопировать формулы в нижележащие ячейки (табл. 1.4).

Таблица 1.4. Фрагмент таблицы умножения
  А В С
1 1 1 =A1*B1
2 =А1+1 =В1+1 =А2*В2
3 =А2+1 =В2+1 =А3*В3
4 =А3+1 =В3+1 =А4*В4
5 =А4+1 =В4+1 =А5*В5
6 =А5+1 =В5+1 =А6*В6
7 =А6+1 =В6+1 =А7*В7
8 =А7+1 =В7+1 =А8*В8
9 =А8+1 =В8+1 =А9*В9

Абсолютные ссылки. Абсолютные ссылки в формулах используются для указания фиксированного адреса ячейки. При перемещении или копировании формулы абсолютные ссылки не изменяются. В абсолютных ссылках перед неизменяемыми именем столбца и номером строки ставится знак доллара (например, $А$1).

Так, при копировании формулы из активной ячейки С1, содержащей абсолютные ссылки на ячейки $А$1 и $В$1, значения столбцов и строк в формуле не изменятся (табл. 1.5).

Таблица 1.5. Абсолютные ссылки
  А В С D Е
1     =$А$1*$В$1    
2       =$А$1*$В$1  
3         =$А$1*$В$1

В качестве примера использования в формуле абсолютной ссылки рассмотрим пересчет цен из долларов в рубли. Ранее была составлена таблица, содержащая цены устройств компьютера в условных единицах. Для того чтобы вычислить цены устройств в рублях, необходимо умножить цену в условных единицах на величину ее курса к рублю.

Пусть названия устройств размещены в ячейках столбца А, их цены в условных единицах - в ячейках столбца В, цены в рублях будут вычисляться в ячейках столбца С, а значение курса условной единицы к рублю хранится в ячейке Е2. Тогда в ячейку С 2 необходимо ввести формулу =В2*$Е$2, содержащую абсолютную ссылку, и скопировать ее в нижележащие ячейки столбца С (табл. 1.6).

Таблица 1.6. Вычисление цены устройств компьютера в рублях по заданному курсу доллара
  А В С D Е
1 Устройство Цена в у.е. Цена в рублях Курс доллара к рублю
2 Системная плата 80 =В2*$Е$2 1 у.е.= 29
3 Процессор 70 =ВЗ*$Е$2    
4 Оперативная память 15 =В4*$Е$2    
5 Жесткий диск 100 =В5*$Е$2    
6 Монитор 200 =В6*$Е$2    
7 Дисковод 3,5" 12 =В7*$Е$2    
8 Дисковод CD-ROM 30 =В8*$Е$2    
9 Корпус 25 =В9*$Е$2    
10 Клавиатура 10 =В10*$Е$2    
11 Мышь 5 =В11*$Е$2    
12 ИТОГО: =СУММ(В2:В11) =СУММ(С2:С11)    

Смешанные ссылки. В формуле можно использовать смешанные ссылки, в которых координата столбца относительная, а строки - абсолютная (например, А$1), или, наоборот, координата столбца абсолютная, а строки - относительная (например, $В1) (табл. 1.7).

Таблица 1.7. Смешанные ссылки
  А В С D Е
1     =A$1*$B1    
2       =B$1*$B2  
3         =C$1*$B3

В качестве примера использования в формуле смешанной ссылки можно рассмотреть пересчет цен из условных единиц в рубли по двум курсам (доллара и евро). Пусть в созданной нами таблице цен устройств компьютера в ячейке Е2 хранится курс доллара к рублю, а в ячейке F2 - курс евро к рублю. Тогда в ячейку С2 необходимо ввести формулу =$В2*Е$2, содержащую смешанные ссылки, и скопировать ее в нижележащие ячейки столбца С, а затем - в соседние ячейки столбца D (табл. 1.8).

Таблица 1.8. Вычисление цены устройств компьютера в рублях по заданным курсам доллара и евро
  А В С D Е F
1 Устройство Цена в у.е. Цена в рублях Цена в рублях Курсы у.е.
2 Системная плата 80 =$В2*Е$2 =$В2*F$2 28 36
3 Процессор 70 =$В3*Е$2 =$В3*F$2    
4 Оперативная память 15 =$В4*Е$2 =$В4*F$2    
5 Жесткий диск 100 =$В5*Е$2 =$В5*F$2    
6 Монитор 200 =$В6*Е$2 =$В6*F$2  
7 Дисковод 3,5" 12 =$В7*Е$2 =$В7*F$2    
8 Дисковод CD-ROM 30 =$В8*Е$2 =$В8*F$2    
9 Корпус 25 =$В9*Е$2 =$В9*F$2    
10 Клавиатура 10 =$В10*Е$2 =$В10*F$2    
11 Мышь 5 =$В11*Е$2 =$В11*F$2    
12 ИТОГО: =СУММ(В2:В11) =СУММ(С2:С11) =СУММ(D2:D11)    
Контрольные вопросы

1. Как изменяется при копировании в ячейку, расположенную в соседнем столбце и строке, формула, содержащая относительные ссылки? Абсолютные ссылки? Смешанные ссылки?

Задания для самостоятельного выполнения

2. Задание с кратким ответом. Какой вид приобретут формулы, хранящиеся в диапазоне ячеек С1:СЗ, при их копировании в диапазон ячеек Е2:Е4?

  А В С D Е
1     =A1+B1    
2     =$А$1*$В$1    
3     =$А1*В$1    
4        

3. Практическое задание. Проверьте в электронных таблицах правильность ответов на предыдущее задание.

Встроенные функции

Формулы могут включать в себя не только адреса ячеек и знаки арифметических операций, но и функции. Электронные таблицы имеют несколько сотен встроенных функций, которые подразделяются на категории: Математические, Статистические, Финансовые, Дата и время и т. д.

Суммирование. Одной из наиболее часто используемых операций является суммирование значений диапазона ячеек. Для этого необходимо выделить диапазон, причем для ячеек, расположенных в одном столбце или строке, достаточно для вызова функции суммирования чисел СУММ() щелкнуть по кнопке Автосумма å на панели инструментов Стандартная.

Результат суммирования будет записан в ячейку, следующую за последней, ячейкой диапазона в столбце (например, =СУММ(А2:А4)), строке (например, =СУММ(С1:Е1)) или прямоугольном диапазоне ячеек (например, =СУММ(СЗ:Е4)) (рис. 1.2).

Рис. 1.2. Суммирование значений диапазонов ячеек

При суммировании значений ячеек выделенный диапазон можно откорректировать путем перемещения границы диапазона с помощью мыши или введением в формулу адресов ячеек с клавиатуры.

Степенная функция. В математике широко используется степенная функция у = хn, где х - аргумент, a n - показатель степени (например, у = х2, у = х3 и т. д.). Ввод функций в формулы можно осуществлять с помощью клавиатуры или с помощью Мастера функций, который предоставляет пользователю возможность вводить функции с использованием последовательностей диалоговых панелей.

Например, если в ячейке В1 хранится значение аргумента х функции, то вид функции, введенной с клавиатуры (ячейка В2), будет =B1^2, а введенной с помощью мастера функций (ячейка ВЗ) - СТЕПЕНЬ(В1;2) (рис. 1.3).

Рис. 1.3. Степенная функция у = х2

Квадратный корень. Квадратный корень является степенной функцией с дробным показателем n = 1/2. Записывается эта функция обычно с использованием знака квадратного корня: у = Öx.

Например, если в ячейке В1 хранится значение аргумента х функции, то вид функции, введенной с клавиатуры (ячейка В2), будет =В1^(1/2), а введенной с помощью мастера функций (ячейка ВЗ) - =КОРЕНЬ(В1) (рис. 1.4).

Рис. 1.4. Квадратный корень у = Öx.

Таблица значений функции. В электронных таблицах можно не только вычислить значение функции для любого заданного значения аргумента, но и представить функцию в форме таблицы числовых значений аргумента и вычисленных значений функции.

Заполнение таблицы можно существенно ускорить, если использовать операцию Заполнить. Сначала в первую ячейку строки аргументов вводится наименьшее значение аргумента (например, в ячейку В1 вводится число -4), а во вторую ячейку вводится формула, вычисляющая следующее значение аргумента с учетом величины шага аргумента (например, =В1+1). Далее эта формула вводится во все остальные ячейки таблицы с использованием операции Заполнить вправо.

Аналогично, в первую ячейку строки значений функции вводится формула вычисления функции (например, в ячейку В2 вводится формула =В1^2), далее эта формула вводится во все остальные ячейки таблицы с использованием операции Заполнить вправо (табл. 1.9).

Таблица 1.9. Числовое представление квадратичной функции у = х2
  А В С D Е F G H I J
1 x -4 -3 -2 -1 0 1 2 3 4
2 y = x^2 16 9 4 1 0 1 4 9 16
Задания для самостоятельного выполнения

4. Задание с кратким ответом. Какие значения будут получены в ячейках А5, F1 и F4 после суммирования значений различных диапазонов ячеек (см. рис. 1.2)? Проверить в электронных таблицах.

5. Задание с кратким ответом. Какие значения будут получены в ячейках В2 и ВЗ после вычисления значений степенной функции (см. рис. 1.3)? Проверить в электронных таблицах.

6. Задание с кратким ответом. Какие значения будут получены в ячейках В2 и ВЗ после вычисления значений квадратного корня (см. рис. 1.4)? Проверить в электронных таблицах.

7. Практическое задание. Построить таблицу значений функции у = Öx. на отрезке [0; 10] с шагом 1.





 У Вас есть материал пишите нам
 
    Copyright © 2008    
Rambler's Top100